Imagine Math is unavailable currently

Major incident Portal Apps (Classlink) Imagine Learning
2022-08-23 02:29 PM CDT · 16 hours, 36 minutes

Updates

Resolved

From Imagine Learning: We are happy to report that users should now be able to resume activities without difficulty.

We apologize for the prior inconvenience.

If you continue to experience issues please contact helpdesk.

August 24, 2022 · 07:06 AM CDT
Investigating

From Imagine Learning: Our team is actively investigating an issue impacting users of Imagine Math.

Students, Educators are not able to login to Imagine Math.

Imagine Learning Status Page

August 23, 2022 · 02:31 PM CDT

← Back