Outbound Calls unavailable

Major incident Phone System (VoIP)
2022-08-04 08:12 CST · 45 minutes

Updates

Resolved

The issue with phones making external calls has been resolved. If you continue to experience issues please contact our helpdesk at x81000

August 4, 2022 · 08:58 AM CST
Issue

We are experiencing an issue with our phones and currently cannot make outbound calls, for emergencies please use your cellphone. If you have any questions please contact helpdesk at x81000

August 4, 2022 · 08:13 AM CST

← Back