Outbound Calls unavailable

Major incident Phone System (VoIP)
2022-08-01 07:48 AM CDT · 34 minutes

Updates

Resolved

We have resolved the phone issue, inbound and outbound calls are now available from the district. If you continue to have issues please contact the helpdesk at x81000.

August 1, 2022 · 08:22 AM CDT
Investigating

We’re investigating an issue with sending and receiving outbound calls, 911 is also effected. Please use your cell for emergency calls, If you need assistance please call helpdesk at x81000

August 1, 2022 · 07:51 AM CDT

← Back