Mimecast Outlook Extension issue

Minor incident Mimecast
2022-07-28 11:12 AM CDT · 5 hours, 25 minutes

Updates

Resolved

The issue between the Mimecast authentication window and Classlink has been resolved.

July 28, 2022 · 04:38 PM CDT
Investigating

We’re investigating an issue with logging into the Mimecast for outlook extension. You can login to your Mimecast personal portal through the district portal to still access these functions for now. If you need assistance please contact the helpdesk at x81000

July 28, 2022 · 11:13 AM CDT

← Back