Classlink Intermittent Issue

Minor incident Portal (Classlink)
2022-06-21 10:22 AM CDT · 31 minutes

Updates

Resolved

From Classlink: The system appears to be back to normal. We’ll monitor the system throughout the day. Thanks for your patience.

If you continue to experience issues please contact the helpdesk at x81000 or email helpdesk@nisdtx.org

June 21, 2022 · 10:54 AM CDT
Issue

From Classlink: We’ve received reports of intermittent issues accessing LaunchPad. It does not appear to be isolated to ClassLink. We are investigating with our service provider.

Classlink Status Page

June 21, 2022 · 10:24 AM CDT

← Back