Mimecast Degraded Performance

Minor incident Mimecast
2022-05-03 09:16 AM CDT · 5 hours, 2 minutes

Updates

Resolved

Mimecast has resolved their degraded performance, if you continue to experience issues please contact helpdesk.

May 3, 2022 · 02:18 PM CDT
Investigating

Mimecast is experiencing degraded performance currently, this may effect emails being delivered in a timely manner.

Mimecast Status Page

May 3, 2022 · 09:27 AM CDT

← Back