Login Issues

Major incident eFinance eSchool Portal (Classlink)
2022-01-13 08:10 CDT · 59 minutes, 8 seconds

Updates

Resolved

Login issues are resolved. If you continue to experience issues please contact helpdesk.

January 13, 2022 · 09:10 AM CDT
Investigating

Login issues are resolved. If you continue to experience issues please contact helpdesk.

January 13, 2022 · 09:09 AM CDT
Investigating

NISD Portal, eSchool and potentially other login services are experiencing intermittent issues. These issues are being investigated.

January 13, 2022 · 08:26 AM CDT

← Back