Intermittent Access Errors

Minor incident NISD Website
2022-01-04 15:12 CDT · 1 week, 1 day, 17 hours, 58 minutes, 3 seconds

Updates

Resolved

Access issues with our website have been resolved. If you continue to experience issues please contact helpdesk.

January 13, 2022 · 09:10 AM CDT
Issue

Finalsite is currently experiencing intermittent issues with webpages loading. We are monitoring the issue and will report any changes as they become available.

January 4, 2022 · 03:14 PM CDT

← Back