Internet Slowness

Minor incident Wired Internet Wireless Internet
2021-12-15 09:32 CDT · 1 hour, 45 minutes

Updates

Resolved

Region11 is reporting that upstream internet issues have been resolved. If you continue to experience issues please contact the helpdesk.

December 15, 2021 · 11:17 AM CDT
Issue

We are currently experiencing some slow internet issues with our upstream internet providers.

December 15, 2021 · 09:33 AM CDT

← Back