Imagine Math Outage

Major incident Portal Apps (Classlink) Imagine Learning
2021-12-02 08:45 AM CDT · 37 minutes

Updates

Resolved

Update from Imagine Learning: We are pleased to announce that the Imagine Math platform is currently functioning normally.

As previously reported, students and educators were having difficulty logging in and using the platform.

Our Operations team has implemented a solution and it appears to have resolved this issue. We will actively monitor the service to ensure the issues do not recur. Thank you for your patience.

Imagine Learning Status page.

December 2, 2021 · 09:22 AM CDT
Issue

We are aware of an Imagine Math outage causing login issues for the platform. Their support is actively working towards resolution.

Imagine Learning Status page.

December 2, 2021 · 08:51 AM CDT

← Back