Timeclock Plus Outage

Minor incident Timeclock Plus
2021-11-05 17:01 CDT · 1 week, 2 days, 16 hours, 8 minutes

Updates

Resolved

Issues with Timeclock Plus have been resolved. If you’re having problems please contact helpdesk.

November 15, 2021 · 08:10 AM CDT
De-escalate

TimeClock Plus access has been restored for most users. If you are still experiencing issues please contact helpdesk.

November 10, 2021 · 08:35 AM CDT
Escalate

Time Clock Plus is experiencing issues with login. We are working with their tech support to provide a solution.

November 9, 2021 · 09:14 AM CDT
De-escalate

The TCP login issue seems to be effecting less users but is still effecting some. If you are unable to clock in or out through the portal, please contact helpdesk.

November 9, 2021 · 07:56 AM CDT
Issue

Timeclock Plus is currently experiencing an outage with logging in.

November 5, 2021 · 05:02 PM CDT

← Back