Imagine Learning

Minor incident Portal Apps (Classlink) Imagine Learning
2021-05-21 09:01 AM CDT · 3 days, 1 hour, 57 minutes

Updates

Resolved

Imagine Math reported an outage Friday and issue is now resolved.

November 4, 2021 · 10:25 AM CDT
Issue

Imagine Learning has posted a “Partial Outage” for Single Sign On (SSO). Impacted users will see an “Invalid authentication token” error when trying to log in from the portal.

November 4, 2021 · 10:25 AM CDT

← Back