Classlink Login Page error

Minor incident Portal (Classlink)
2021-05-12 08:14 AM CDT · 1 day, 3 hours, 27 minutes

Updates

Resolved

Issue has been resolved and working for 24 hours.

November 4, 2021 · 10:25 AM CDT
De-escalate

The NISD technology engineering team designed an alternative solution to allow NISD students and staff to log into the portal while ClassLink continues to investigate the issue. Access is now restored.

status.nisdtx.org

status.classlink.com

November 4, 2021 · 10:25 AM CDT
Investigating

We’re currently experiences issues with Classlink launch pad and have reached out to Classlink support for assistance. This impacts ability to login through a Chromebook or into the portal.

Classlink Status page.

November 4, 2021 · 10:25 AM CDT

← Back