Teacher Access Center Login Issue

Minor incident Teacher Access Center
2021-05-06 08:19 AM CDT · 4 days, 5 hours, 48 minutes

Updates

Resolved

TAC access has been restored. In association with Powerschool the issue was identified and repaired. If you experience further issues with TAC, please put in a helpdesk ticket.

November 4, 2021 · 10:25 AM CDT
Investigating

Updates have been applied to the servers and we have seen improved login performance. We are continuing to monitor for any remaining issues.

November 4, 2021 · 10:25 AM CDT
Issue

Teacher Access Center (TAC) is experiencing intermittent issues and reporting “System Unavailable”. We’re working with our support vendor to resolve this as quickly as possible.

November 4, 2021 · 10:25 AM CDT

← Back