Google Drive issue

Major incident Google Suite for EDU Google Drive
2021-04-12 09:15 CDT · 3 hours, 53 minutes, 29 seconds

Updates

Resolved

Update From Google: The problem with Google Docs has been resolved. We apologize for the inconvenience and thank you for your patience and continued support. Please rest assured that system reliability is a top priority at Google, and we are making continuous improvements to make our systems better.

Please try reloading the page, or coming back to it in a few minutes.

Google Status Page.

April 12, 2021 · 01:09 PM CDT
Investigating

Update from Google: Our team is continuing to investigate this issue. We will provide an update by 4/12/21, 11:00 AM with more information about this problem. Thank you for your patience. The affected users are able to access Classroom, but are seeing error messages, high latency, and/or other unexpected behavior.

Google Status Page.

April 12, 2021 · 10:36 AM CDT
Investigating

Updated: Google is reporting issues with Drive and related applications such as Docs, Sheets, Slides and Google Classroom. We will update as we get more information.

Google Status Page.

April 12, 2021 · 09:37 AM CDT
Issue

Google is reporting issues with Drive and Drive applications such as Docs, Sheets, and Slide. We will update as we get more information.

Google Status Page.

April 12, 2021 · 09:21 AM CDT

← Back