Timeclock Plus DNS Error

Major incident Timeclock Plus
2021-03-05 08:52 CDT · 7 hours, 12 minutes, 28 seconds

Updates

Resolved

Time Clock Plus has resolved the login issue.

March 5, 2021 · 04:04 PM CDT
Investigating

We are aware of an issue with Time Clock Plus being unavailable. We are working with the vendor to address this issue.

March 5, 2021 · 08:53 AM CDT

← Back