Lexia outage

Major incident Portal Apps (Classlink) Lexia
2021-03-01 10:29 CDT · 3 hours, 42 minutes, 57 seconds

Updates

Resolved

Lexia has implemented a fix and are monitoring the results.

March 1, 2021 · 02:12 PM CDT
Issue

Students and staff may experience interruptions or error screens when trying to access our products. Lexia apologizes for the inconvenience and thank you for your patience! Lexia is currently investigating this issue and will update once they know more about the root cause.

March 1, 2021 · 10:32 AM CDT

← Back