Internet Connectivity issues

Minor incident Wired Internet Wireless Internet
2021-02-23 10:57 CDT · 3 hours, 21 minutes, 25 seconds

Updates

Resolved

We have resolved the internet connectivity issues. If you are still experiencing issues let helpdesk know.

February 23, 2021 · 02:18 PM CDT
Issue

We are currently working with our internet provider to correct connectivity issues.

February 23, 2021 · 10:58 AM CDT

← Back