Portal Login issue

Major incident Portal (Classlink)
2021-02-10 08:04 CDT · 9 minutes, 37 seconds

Updates

Resolved

Classlink has resolved the login issues with the portal.

February 10, 2021 · 08:13 AM CDT
Issue

Classlink is currently experiencing login related issues. The company is investigating.

February 10, 2021 · 08:08 AM CDT

← Back