Home Page unreachable

Major incident NISD Website
2021-02-04 15:41 CDT · 3 days, 18 hours, 15 minutes, 6 seconds

Updates

Resolved

School Messenger has restored access to the NISD website.

February 8, 2021 · 09:56 AM CDT
Issue

School Messenger, our website vendor, has informed NISD that their customer websites are inaccessible.

February 4, 2021 · 03:53 PM CDT

← Back