Lexia Learning is currently experiencing issues.

Major incident Portal Apps (Classlink) Lexia
2020-12-15 08:42 CDT · 22 hours, 35 minutes, 19 seconds

Updates

Resolved

Testing shows that Lexia appears to be working this morning though they never issued an official incident or resolution. If you run into issues Lexia please let us know.

December 16, 2020 · 07:17 AM CDT
Issue

Lexia Learning is currently experiencing issues after log in. We are working with Lexia support to find a resolution. We will provide updates when available.

December 15, 2020 · 08:59 AM CDT

← Back