Email Delay

Minor incident Cisco Network Security Iron Port Email Security
2020-11-16 08:30 CDT · 4 hours, 30 minutes, 48 seconds

Updates

Resolved

The delay is resolved in mail delivery now.

November 16, 2020 · 01:01 PM CDT
Investigating

We are currently investigating a delay in email messages.

November 16, 2020 · 08:35 AM CDT

← Back