Portal 404 Error

Major incident Portal (Classlink)
2020-11-16 07:12 CDT · 5 hours, 48 minutes, 14 seconds

Updates

Resolved

Classlink has resolved the issue they were having and the portal is back up.

November 16, 2020 · 01:00 PM CDT
Investigating

Classlink is Investigating the login issue, currently no ETA on resolution.

This is Classlinks Status Page

November 16, 2020 · 07:47 AM CDT
Issue

Currently users trying to reach portal.nisdtx.org are receiving a 404 error. We have reached out to Classlink regarding it.

November 16, 2020 · 07:13 AM CDT

← Back