Email delivery disruption
Major incident
Microsoft
Outlook Web App
2026-01-22 02:37 PM CST
· 16 hours, 22 minutes
Updates
Resolved
January 23, 2026 · 07:00 AM CST
Microsoft’s outage has been resolved and services have been restored, if you continue too experience issues please contact helpdesk at x81000
Issue
January 22, 2026 · 02:37 PM CST
Microsoft is experiencing issues with accessing 365 related services, we’re seeing this effecting email sending and receiving currently but it could be effecting other services, we’re monitoring the situation and will be updating as we get more information.
← Back
Northwest ISD Status