Portal Outage

Major incident Portal (Classlink)
2026-01-20 10:54 AM CST · 35 minutes

Updates

Resolved

From Classlink - All services should be restored.

If you continue to experience issues please contact helpdesk at x81000

January 20, 2026 · 11:30 AM CST
Investigating

From Classlink - We are currently experience an issue with Classlink LaunchPad logins and within MyApps. We are aware of the issue and are actively investigating the issue.

January 20, 2026 · 10:54 AM CST

← Back