Origo Outage
Major incident
Portal Apps (Classlink)
Origo
2026-01-15 10:35 AM CST
· 5 hours, 21 minutes
Updates
Resolved
January 15, 2026 · 03:56 PM CST
The outage has been resolved and users should be able to access Origo again, if you continue to experience issues please contact helpdesk at x81000
Investigating
January 15, 2026 · 10:35 AM CST
Currently users are unable to login to Origo and are loading a blank screen. We’re working with Origo to resolve the issue.
← Back
Northwest ISD Status