Internet loading issues
Major incident
Wired Internet
Wireless Internet
2025-12-17 10:08 AM CST
· 1 hour, 35 minutes
Updates
Resolved
December 17, 2025 · 11:42 AM CST
We have located the issue and corrected it, internet traffic should be flowing normally now. If you continue to experience issues please contact the helpdesk at x81000
Issue
December 17, 2025 · 10:08 AM CST
We’re currently experiencing issues loading websites both internal and external resources, we’re investigating and will post updates when available.
← Back
Northwest ISD Status