Service Outage

Major incident Schoolcash
2025-10-29 12:02 PM CDT · 1 day, 59 minutes

Updates

Resolved

Services have been restored by Microsoft and access has been restored. If you continue to experience issues please contact helpdesk at x81000

October 30, 2025 · 01:01 PM CDT
Issue

We are currently experiencing issues with some web services due to an outage outside of our control. We will update you when we have more information.

October 29, 2025 · 12:02 PM CDT

← Back