Students unable to login to Edgenuity

Major incident Edgenuity
2020-09-24 10:51 CST · 1 day, 46 minutes, 17 seconds

Updates

Resolved

Edgenuity login issues for students are resolved. If you continue to have issues please let us know.

September 25, 2020 · 11:37 AM CST
Issue

We are currently investigating an issue with Edgenuity. The issue affects all students. Students may continue to use the platform during the issue and we hope to have a resolution soon.

September 24, 2020 · 10:51 AM CST

← Back