Destiny Login Issues

Major incident Follett Destiny
2020-09-23 16:55 CDT · 20 hours, 41 minutes, 25 seconds

Updates

Resolved

Destiny has reported this issue as resolved

September 24, 2020 · 01:36 PM CDT
Investigating

Follett Destiny has reported login issues for Single-Sign On and are currently investigating. SSO may not work during this time.

September 23, 2020 · 04:56 PM CDT

← Back