Portal Slow login issue

Minor incident Portal (Classlink)
2020-09-21 08:36 CST · 1 hour, 35 minutes, 8 seconds

Updates

Resolved

Classlink has reported that the slow login issue is resolved.

September 21, 2020 · 10:11 AM CST
Investigating

Classlink is investigating slow login issues

September 21, 2020 · 08:36 AM CST

← Back