Unable to Access Portal

Minor incident Portal (Classlink)
2025-10-20 07:12 AM CDT · 1 day, 14 minutes

Updates

Resolved

Services have been fully restored to the Portal, if you continue to experience issues loading the portal please contact helpdesk at x81000

October 21, 2025 · 07:27 AM CDT
De-escalate

Portal accessibility has been restored, we’re currently monitoring the situation. Portal loading is currently slow for some users as services are still being restored.

October 20, 2025 · 02:21 PM CDT
Investigating

If you need to clock-in please click HERE or go to app.redroverk12.com

October 20, 2025 · 07:38 AM CDT
Issue

AWS experienced a large outage this morning that they are working to resolve that has effected Classlink. Services should slowly start functioning again this morning as they work to resolve the issue.

Classlink Status Page

AWS Status Page

October 20, 2025 · 07:12 AM CDT

← Back