Imagine Math inaccessible

Major incident Portal Apps (Classlink) Imagine Learning
2025-10-10 10:27 AM CDT · 4 days, 23 hours, 54 minutes

Updates

Resolved

Imagine Math has deployed a fix, users should be able to sign in again. If you continue to experience sign-in problems please contact helpdesk at x81000

October 15, 2025 · 10:21 AM CDT
Investigating

We are investigating an error within the Imagine Learning platform that is preventing our students from logging in to Imagine Math. We are in contact with Imagine Learning technical support and will update when we have resolution.

October 14, 2025 · 08:14 AM CDT
Investigating

Imagine math has resolved the sign in issue, if you continue to have problems please contact the helpdesk at x81000

October 13, 2025 · 02:24 PM CDT
Investigating

We are investigating an error within the Imagine Learning platform that is preventing our students from logging in to Imagine Math. We are in contact with Imagine Learning technical support and will update when we have resolution.

October 10, 2025 · 10:27 AM CDT

← Back