Turnitin Service down
      
Major incident
      
    
    
      
2020-09-11 07:00 AM CDT
      
      · 6 days, 7 hours, 22 minutes
    
  Updates
          Resolved
        
        
November  4, 2021 · 10:24 AM CDT
        
      
      Turnitin has resolved the certification issue on their end and it is up and running in Moodle now.
          Issue
        
        
November  4, 2021 · 10:24 AM CDT
        
      
  We have been in contact regarding the Turnitin Plugin effecting service with Moodle
← Back
 Northwest ISD Status
            
Northwest ISD Status