Google Drive issues

Minor incident Google Drive Google Suite for EDU
2020-09-15 09:00 CST · 2 hours, 36 minutes, 33 seconds

Updates

Resolved

Update from Google “The problem with Google Drive should be resolved. We apologize for the inconvenience and thank you for your patience and continued support. Please rest assured that system reliability is a top priority at Google, and we are making continuous improvements to make our systems better.”

September 15, 2020 · 11:36 AM CST
Investigating

This is Googles Status link

September 15, 2020 · 10:12 AM CST
Issue

Some users are having difficulty searching for docs in Google Drive. Works for some, others get an error message that says “The Server encountered an error. Please try again later”

September 15, 2020 · 09:35 AM CST

← Back