Google SSO Issue
Major incident
Google Suite for EDU
Google Admin
Google Drive
Gmail
Youtube
2025-09-18 10:35 AM CDT
· 1 hour, 12 minutes
Updates
Resolved
September 18, 2025 · 11:47 AM CDT
Google is reporting that they have taken mitigation steps and the issue should be resolved now. If you continue to experience issues people contact helpdesk at x81000
Issue
September 18, 2025 · 10:35 AM CDT
Google is currently experiencing SSO issues that is causing login issues with classroom and Lightspeed classroom. They are working to resolve the issue as quickly as possible. Refreshing and clearing cache has shown to help some.
← Back
Northwest ISD Status