Youtube Connectivity issues

Minor incident Google Suite for EDU Youtube
2025-02-21 08:59 AM CST · 1 month, 1 week, 3 days, 18 hours, 55 minutes

Updates

Investigating

We have gotten some reports that rebooting your computer has helped with the connectivity issue.

February 21, 2025 · 09:09 AM CST
Issue

Youtube is experiencing some irregular connectivity issues causing videos not to load

February 21, 2025 · 08:59 AM CST

← Back