Duo Auth

Major incident DUO
2025-02-13 12:53 PM CST · 19 hours, 29 minutes

Updates

Resolved

DUO has resolved the sign-in issue and services have been restored, if you continue to experience issues signing in with DUO please contact the helpdesk at x81000

February 14, 2025 · 08:22 AM CST
Issue

Duo is reporting issues with some MFA logins, particularly ones requiring phone/SMS codes. If you are having issues logging in or need a bypass code please contact the helpdesk

https://status.duo.com/

February 13, 2025 · 12:53 PM CST

← Back