Issues sending Faxes

Major incident Faxes
2025-01-22 08:19 AM CST · 23 hours, 50 minutes

Updates

Resolved

We have restored the ability to send faxes, if you continue to experience problems please contact the helpdesk at x81000

January 23, 2025 · 08:09 AM CST
Investigating

We’re currently experiencing issues with sending faxes and are working to resolve it as quickly as possible, sorry for the inconvenience.

January 22, 2025 · 08:19 AM CST

← Back