Imagine Learning Slowness

Minor incident Portal Apps (Classlink) Imagine Learning
2024-12-02 09:04 AM CST · 5 hours, 57 minutes

Updates

Resolved

Imagine Learning is reporting that the issue is resolved, if you continue to experiences issues please contact our helpdesk at x81000

December 2, 2024 · 03:02 PM CST
Issue

Imagine Learning is reporting that some Imagine Espanol, and Language and Literacy users may be experiencing slowness or errors, they are currently investigating the issue.

December 2, 2024 · 09:04 AM CST

← Back