Outlook Performance Issues

Minor incident Microsoft Outlook Web App Office 365
2024-10-10 11:16 AM CDT · 2 hours, 20 minutes

Updates

Resolved

Update from Microsoft: We’ve applied a config change and telemetry has confirmed we’ve mitigated impact. Users should refresh/restart their Outlook sessions.

If you continue to experience issues please contact our helpdesk at x81000

October 10, 2024 · 01:34 PM CDT
Investigating

Microsoft is investigating Outlook issues

From Microsoft - Users may experience performance issues with the Outlook Client with errors stating it is using increased resources and the client may freeze or crash.

For users with access to Outlook on the web they may be able to use that platform as a workaround.

October 10, 2024 · 11:16 AM CDT

← Back