BrainPOP Login Issues

Minor incident Portal Apps (Classlink) BrainPOP
2024-05-20 11:34 AM CDT · 1 hour, 36 minutes

Updates

Resolved

The incident with SSO logins has been resolved, if you continue to having login issues please clear your cache and cookies, if they persist then please contact helpdesk at x81000

May 20, 2024 · 01:10 PM CDT
Investigating

From BrainPOP: We are currently investigating an issue with LTI login errors to our application homepages. We are actively looking into this issue and will provide an update as soon as possible!

BrainPOP Status Page

May 20, 2024 · 11:34 AM CDT

← Back