Portal Login Issues

Major incident Portal (Classlink)
2024-03-07 07:14 AM CDT · 40 minutes

Updates

Resolved

Classlink login capabilities have been restored, Staff and students should be able to login to their portals now. If you continue to experience issues logging in please contact helpdesk at x81000

March 7, 2024 · 07:53 AM CDT
Issue

The portal managed by Classlink is currently encountering login problems for all staff and sporadic issues for students. Classlink is actively investigating the problem with the Portal login page. We apologize for any inconvenience caused and will provide updates as they become available. For the latest updates, please refer to the following status pages:
Classlink Status Page: [https://status.classlink.com/]
NISD Status Page: status.nisdtx.org
NISD Status Page: status.nisdtx.org

March 7, 2024 · 07:14 AM CDT

← Back