Edugence Reporting issue

Major incident Edugence
2024-02-08 01:00 PM CDT · 22 hours, 35 minutes

Updates

Resolved

Update made to file, confirmed improved reporting.

February 9, 2024 · 11:36 AM CDT
Investigating

The reporting issue with Edugence has been resolved. If you continue to experience problems please contact helpdesk at x81000

February 9, 2024 · 11:35 AM CDT
Investigating

We are currently working on the Edugence reporting issue with the vendor and hope to have it resolved shortly. Sorry for the inconvenience and thank you for your patience.

February 8, 2024 · 01:00 PM CDT

← Back