Classlink Login Issues

Minor incident Portal (Classlink)
2024-01-22 07:49 AM CDT · 46 minutes

Updates

Resolved

From Classlink - Resolved - This incident has been resolved. If users continue to experience issues, please contact helpdesk.

January 22, 2024 · 08:35 AM CDT
Investigating

From Classlink - Investigating - A LaunchPad login issue has been identified affecting a subset of customers. Users may receive a timeout message when attempting to log in to LaunchPad. We are investigating and will post updates as soon as possible.

Classlink Status Page

January 22, 2024 · 07:49 AM CDT

← Back