Gmail Disruption

Minor incident Google Suite for EDU Gmail
2023-11-30 12:38 PM CDT · 4 hours, 26 minutes

Updates

Resolved

Google is reporting the email delay issue has been resolved. Gmail delivery should be working for new emails. However, older emails will be automatically retried and should be delivered within the next couple of hours.

November 30, 2023 · 05:01 PM CDT
Issue

Google has identified and issue impacting Gmail that is causing some users to experience a delay in sending emails.

They are working on mitigation for the issue but there is currently no ETA for resolution.

This could potentially impact some student mail accounts. We’ll post an update once the issue is resolved or if there are any changes.

https://www.google.com/appsstatus/

November 30, 2023 · 12:38 PM CDT

← Back