Unable to run reports in eSchool
      
Major incident
      
        eSchool
    
    
      
2023-10-10 07:46 AM CDT
      
      · 3 hours, 18 minutes
    
  Updates
          Resolved
        
        
October 10, 2023 · 11:01 AM CDT
        
      
      Reports are now running in Powerschool. Please contact the helpdesk at x81000 if you have any problems. Thank you
          Investigating
        
        
October 10, 2023 · 07:46 AM CDT
        
      
  eSchool is experiencing a technical issue that is preventing us from running reports. We have contacted their support team and are working to resolve the issue as quickly as possible. We will provide updates as we have more information.
← Back
 Northwest ISD Status
            
Northwest ISD Status