Imagine Math Outage

Minor incident Portal Apps (Classlink) Imagine Learning
2023-09-11 10:21 AM CST · 1 day, 3 hours, 33 minutes, 1 second

Updates

Resolved

Imagine Learning has resolved the login issues with Imagine Math

September 12, 2023 · 01:54 PM CST
De-escalate

From Imagine Learning - A fix has been implemented and we are monitoring the results.

September 11, 2023 · 02:16 PM CST
Escalate

Major outage

September 11, 2023 · 10:22 AM CST
Investigating

From Imagine Learning - Investigating - Our team is actively investigating an issue impacting users of Imagine Math and Imagine Math Facts.

Students and Educators cannot open Imagine Math and Imagine Math Facts.

Imagine Learning Status Page.

September 11, 2023 · 10:21 AM CST

← Back