Follett Destiny SSO not functioning

Major incident Follett Destiny
2023-08-25 08:09 AM CST · 3 hours, 20 minutes

Updates

Resolved

resolved

August 25, 2023 · 11:29 AM CST
Investigating

We have resolved the sign-in issues with Follett Destiny, thank you for your patience. If you continue to experience login issues please contact helpdesk at x81000

August 25, 2023 · 11:28 AM CST
Escalate

Escalating incident

August 25, 2023 · 08:29 AM CST
Investigating

We are experiencing issues with Single-Sign on with the portal into Follett Destiny and are investigating and working to resolve the issue ASAP.

August 25, 2023 · 08:09 AM CST

← Back