DUO

Major incident DUO
2023-08-17 07:50 AM CST · 3 hours, 26 minutes

Updates

Resolved

All Systems Operational

August 17, 2023 · 11:16 AM CST
Investigating

Investigating - We are currently investigating an issue causing SMS and Phone Call delivery failures to US and Canada numbers and are working to correct the issue as soon as possible.

August 17, 2023 · 07:50 AM CST

← Back